summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-10 22:17:19 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:55 +0000
commit82ffd10e3e84b4a4601b342ddc81ba9dbc72377d (patch)
tree2326bc5fa7a9685d23392bc4ecf508030bb470cb /gnu/packages/golang-xyz.scm
parentbe17092eba6a524e6299422c5fe7a982681d1498 (diff)
gnu: Add go-porter2.
* gnu/packages/golang-xyz.scm (go-porter2): New variable. Change-Id: Ie0dd95b5efaee5716245da7e6c46577c8620f9ad
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d6b6ff89f5..4e961583fa 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16579,6 +16579,46 @@ go-github-com-tklauser-numcpus source.")))
"This package provides a CLI build from the
go-github-com-orisano-pixelmatch source.")))
+(define-public go-porter2
+ (package
+ (inherit go-github-com-surgebase-porter2)
+ (name "go-porter2")
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments go-github-com-surgebase-porter2)
+ ((#:tests? _ #t) #f)
+ ((#:install-source? _ #t) #f)
+ ((#:unpack-path _) "github.com/surgebase/porter2")
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ (replace 'build
+ (lambda arguments
+ (for-each
+ (lambda (cmd)
+ (apply (assoc-ref %standard-phases 'build)
+ `(,@arguments #:import-path ,cmd)))
+ (list "github.com/surgebase/porter2/cmd/compare"
+ "github.com/surgebase/porter2/cmd/suffixfsm"
+ "github.com/surgebase/porter2/cmd/switchvsmap"))))
+ (replace 'install
+ (lambda arguments
+ (for-each
+ (lambda (cmd)
+ (apply (assoc-ref %standard-phases 'install)
+ `(,@arguments #:import-path ,cmd)))
+ (list "github.com/surgebase/porter2/cmd/compare"
+ "github.com/surgebase/porter2/cmd/suffixfsm"
+ "github.com/surgebase/porter2/cmd/switchvsmap"))))))))
+ (description
+ (string-append (package-description go-github-com-mattn-go-sixel)
+ " This package provides an command line interface (CLI)
+tools:
+@itemize
+@item @code{compare}
+@item @code{suffixfsm} is a finite state machine generator for the porter2
+@item @code{switchvsmap}
+@end itemize"))))
+
(define-public go-sentences
(package
(inherit go-github-com-neurosnap-sentences)