summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 20:41:32 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:50 +0000
commit6ad2d96663ab699d2638378fe83af549c2a7cbde (patch)
treee3a54e1b037c9be3c85562916cbf1a84973a80df /gnu/packages/golang-xyz.scm
parent4d0de227e067cd60a4a7eb851adc0bc8966d0f39 (diff)
gnu: go-github-com-git-lfs-go-netrc: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-git-lfs-go-netrc): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I958e375e5bb6eec173b3b75d189491e5bc132827
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5477ca3101..330e59982f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5066,6 +5066,32 @@ also favors portability, and includes support for all POSIX systems.")
(modify-inputs (package-inputs go-github-com-gdamore-tcell)
(prepend go-golang-org-x-term go-golang-org-x-sys))))))
+(define-public go-github-com-git-lfs-go-netrc
+ (package
+ (name "go-github-com-git-lfs-go-netrc")
+ (version "0.0.0-20230601124202-e96144b9a966")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/git-lfs/go-netrc")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rb8xk0gp7yvw10zs122p48qhj3xc9csaykbflr7wdfx5xqpbr2f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:skip-build? #t
+ #:import-path "github.com/git-lfs/go-netrc"))
+ (home-page "https://github.com/git-lfs/go-netrc")
+ (synopsis "Netrc file parser for Go")
+ (description
+ "This package is for reading and writing netrc files. This package can
+parse netrc files, make changes to them, and then serialize them back to netrc
+format, while preserving any whitespace that was present in the source file.")
+ (license license:expat)))
+
(define-public go-github-com-gizak-termui-v3
(package
(name "go-github-com-gizak-termui-v3")