summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-08 20:53:35 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:46 +0000
commit5646fb717dcfc6bca4a9db691f2fd33183059eb4 (patch)
treeb1168108ec3eba8f720fce4da850b871bc2cbe3a /gnu/packages/golang-xyz.scm
parentfc07de05d7b300787aa68a5213a39b63db906879 (diff)
gnu: go-github-com-kataras-pio: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-kataras-pio): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ibbd6329cb264458d03e3da64d6a051b360d0d8d3
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d7fd1f4a3e..54885d2b90 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8244,6 +8244,31 @@ them.")
"Go long flag: a light-weight long and short command line option parser.")
(license license:bsd-3)))
+(define-public go-github-com-kataras-pio
+ (package
+ (name "go-github-com-kataras-pio")
+ (version "0.0.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kataras/pio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z0fkhs6amnkvb02519pfxy2x2r5sfmvdzxfi31ipa17m98pk3bq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kataras/pio"))
+ (home-page "https://github.com/kataras/pio")
+ (synopsis "Pill for Input/Output")
+ (description
+ "PIO is a low-level package that provides a way to centralize different
+output targets. Supports colors and text decoration to all popular
+terminals.")
+ (license license:bsd-3)))
+
(define-public go-github-com-kballard-go-shellquote
;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
(let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")