summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 22:12:49 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:51 +0000
commit46e69fc5530941ef8d9fe8f7e1c3f98a6cee0a3c (patch)
treeaefd16a1ee39d0297a9e687993ce4449eb2f4355 /gnu/packages/golang-xyz.scm
parenta0e06194c6f13a4c917aec7fa827394d1a70fdea (diff)
gnu: go-github-com-rcrowley-go-metrics: Update to 0.0.0-20201227073835-cf1acfcdf475.
* gnu/packages/golang-xyz.scm (go-github-com-rcrowley-go-metrics): Update to 0.0.0-20201227073835-cf1acfcdf475. Change-Id: I79f15d5a32ec274a544fe8bdd2e4bba3d11335b5
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 632497fe07..7f71d728af 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -11831,20 +11831,18 @@ policy.")
(license (list license:asl2.0 license:expat))))
(define-public go-github-com-rcrowley-go-metrics
- (let ((commit "cac0b30c2563378d434b5af411844adff8e32960")
- (revision "2"))
(package
(name "go-github-com-rcrowley-go-metrics")
- (version (git-version "0.0.0" revision commit))
+ (version "0.0.0-20201227073835-cf1acfcdf475")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rcrowley/go-metrics")
- (commit commit)))
+ (commit (go-version->git-ref version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hfxffnpaw49pr3wrkbzq3pnv3nyzsvk5dxndv0yz70xlrbg8a04"))))
+ (base32 "0s7zab04slz07c7l4h2cqz62qnqah69r6p157vvbd7725a7wzkr0"))))
(build-system go-build-system)
(arguments
;; Arbitrary precision tests are known to be broken on aarch64, ppc64le
@@ -11858,7 +11856,7 @@ policy.")
(description "This package provides a Go implementation of Coda Hale's
Metrics library.")
(home-page "https://github.com/rcrowley/go-metrics")
- (license license:bsd-2))))
+ (license license:bsd-2)))
(define-public go-github-com-remeh-sizedwaitgroup
(package