summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-08 21:21:50 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:47 +0000
commit35e0667e09eb6f437e2231049025415989c15cbe (patch)
tree88c36541d498e06d87e41d8639d64f4bc69f93e9 /gnu/packages/golang-xyz.scm
parent83669444a17e16b88514d4e20a9a1527ac4a9ce7 (diff)
gnu: go-github-com-leonelquinteros-gotext: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-leonelquinteros-gotext): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ia8817b7ec6edab094ef8e3cf6aebba6854277f3f
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a671a5a041..a7afb6502f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8783,6 +8783,47 @@ structure. It's a stable fork of https://github.com/mndrix/ps.")
specified by @uref{https://tools.ietf.org/html/rfc2141, IETF RFC 2141}.")
(license license:expat)))
+(define-public go-github-com-leonelquinteros-gotext
+ (package
+ (name "go-github-com-leonelquinteros-gotext")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/leonelquinteros/gotext")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ccls9xzbbrbrplbikz18lcky5p5rmifif6w69l5rl34dv11948m"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/leonelquinteros/gotext"))
+ (propagated-inputs
+ (list go-golang-org-x-text
+ go-golang-org-x-tools))
+ (home-page "https://github.com/leonelquinteros/gotext")
+ (synopsis "GNU gettext utilities in Go")
+ (description
+ "This package implements GNU gettext utilities in Go. It features:
+
+@itemize
+@item Implements GNU gettext support in native Go.
+@item Complete support for PO files including:
+@item Support for MO files.
+@item Thread-safe: This package is safe for concurrent use across multiple
+goroutines.
+@item It works with UTF-8 encoding as it's the default for Go language.
+@item Unit tests available.
+@item Language codes are automatically simplified from the form en_UK to en if
+the first isn't available.
+@item Ready to use inside Go templates.
+@item Objects are serializable to []byte to store them in cache.
+@item Support for Go Modules.
+@end itemize")
+ (license license:expat)))
+
(define-public go-github-com-lestrrat-go-envload
(package
(name "go-github-com-lestrrat-go-envload")