summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-25 08:28:17 +0000
committerSharlatan Hellseher <[email protected]>2025-01-25 08:29:25 +0000
commit282775fb67fed9ec225ac51e247e536d724c2d6c (patch)
treed193cde5081df80a7ee280b4440c69c3b454d440 /gnu/packages/golang-xyz.scm
parenta0792c40b272dbc280f42bc2ce17a74b6b9727a8 (diff)
gnu: Add go-github-com-fatih-structtag.
* gnu/packages/golang-xyz.scm (go-github-com-fatih-structtag): New variable. Change-Id: I83942f580d5fcc94e2b098dc68a8c5d0f2bdcc23
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0fa1b5767a..2806fc91c7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5114,6 +5114,30 @@ defined output to the standard output.")
with Go structs.")
(license license:expat)))
+(define-public go-github-com-fatih-structtag
+ (package
+ (name "go-github-com-fatih-structtag")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fatih/structtag")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09a9pycvkf384v5f47ff4q33bjbzpx6kbkn23za1gcwc96466sk3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/fatih/structtag"))
+ (home-page "https://github.com/fatih/structtag")
+ (synopsis "Parse and modify Go struct field tags")
+ (description
+ "This package provides an easy way of parsing and manipulating struct tag fields.
+Please vendor the library as it might change in future versions.")
+ (license license:bsd-3)))
+
;; XXX: This repository has been archived by the owner on Nov 9, 2017. It is
;; now read-only.
(define-public go-github-com-flynn-archive-go-shlex