summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-10 20:35:31 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:54 +0000
commit11bc232176268d4733ae29d0a0f8afa19e8ab782 (patch)
tree7b6eb56daa9dddde0d215b6e3e91366b8121a97f /gnu/packages/golang-xyz.scm
parentd7f4315446db275bc0352c7a474f272fed09eecf (diff)
gnu: go-github-com-kardianos: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-kardianos): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I60104783d67bcb00c2b16069611a72113ec163d3
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5fbd472233..e0a069b643 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8410,6 +8410,31 @@ import this package to enable running programs as services without modifying
them.")
(license license:zlib)))
+(define-public go-github-com-kardianos-osext
+ (package
+ (name "go-github-com-kardianos-osext")
+ (version "0.0.0-20190222173326-2bc1f35cddc0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kardianos/osext")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pvrbrvmrf4mx0fxbfaphbzgqgwn8v6lkfk2vyrs0znxrs1xyc5r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kardianos/osext"))
+ (home-page "https://github.com/kardianos/osext")
+ (synopsis "Find the running executable")
+ (description
+ "Osext provides a method for finding the current executable file that is
+running. This can be used for upgrading the current executable or finding
+resources located relative to the executable file.")
+ (license license:bsd-3)))
+
(define-public go-github-com-kardianos-service
(package
(name "go-github-com-kardianos-service")