summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-06 20:50:23 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:39 +0000
commit0887597c5fe5a0aed981fbf02812a6dfe7f68452 (patch)
tree093ebe717495d882f655ed55502875789d34ec1e /gnu/packages/golang-xyz.scm
parent9a52976e3033ea353dfd291c7f61558e17f83020 (diff)
gnu: go-github-com-robfig-cron-v3: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-robfig-cron-v3): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I6096fa9b398fd12ea1733565658b99054a7512ce
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dfc482792a..55fbcb1d7b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -11056,6 +11056,30 @@ exploration and data entry.")
@url{https://unicode.org/reports/tr29/, Unicode Standard Annex #29}.")
(license license:expat)))
+(define-public go-github-com-robfig-cron-v3
+ (package
+ (name "go-github-com-robfig-cron-v3")
+ (version "3.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/robfig/cron")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1agzbw2dfk2d1mpmddr85s5vh6ygm8kqrvfg87i9d2wqnlsnliqm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/robfig/cron/v3"))
+ (home-page "https://godoc.org/github.com/robfig/cron")
+ (synopsis "Cron library for Go")
+ (description
+ "This package provides a cron library for Go. It implements a cron spec
+parser and job runner.")
+ (license license:expat)))
+
(define-public go-github-com-rogpeppe-fastuuid
(package
(name "go-github-com-rogpeppe-fastuuid")