summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-11 14:49:53 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:58 +0000
commit04ca445dd289975c0b5f49ca9cae578027783cdf (patch)
tree5c8f4a11a8af5d297fac6f2161b6458349fe1735 /gnu/packages/golang-xyz.scm
parent22b4bd772ab9beb6c3c9088b01d724a2104b6a4f (diff)
gnu: Add go-github-com-templexxx-cpu.
* gnu/packages/golang-xyz.scm (go-github-com-templexxx-cpu): New variable. Change-Id: I19b13fefdce5d00f8f5f86d09dd41b3f789669cb
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cff3afcc7d..65a1e8029d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -13864,6 +13864,30 @@ Included modules are:
@end itemize")
(license license:expat)))
+(define-public go-github-com-templexxx-cpu
+ (package
+ (name "go-github-com-templexxx-cpu")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/templexxx/cpu")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bfygzjz2n8fbc9n9k7hfdnaz5mw6g4n4n1q3a0hyv33j9bvl5hh"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/templexxx/cpu"))
+ (home-page "https://github.com/templexxx/cpu")
+ (synopsis "@code{internal/cpu} in Go (add AVX512)")
+ (description
+ "Package cpu implements processor feature detection used by the Go
+standard library.")
+ (license license:bsd-3)))
+
(define-public go-github-com-thejerf-suture
(package
(name "go-github-com-thejerf-suture")