summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-06 20:55:49 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:39 +0000
commit2a01c33232037b0eefde326b3909bdadb72b6271 (patch)
treebd0e510b694f59911a72b74d59fdbaf7e79e9bfa /gnu/packages/golang-web.scm
parent3fba3e0bcfd4d8abc87ea388bfac88f5990efa6b (diff)
gnu: go-github-com-macronut-go-tproxy: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-macronut-go-tproxy): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: Ie0faee29489ffc89812d310eb3ccc5b0af642779
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c5ee1f62c1..8ae530e46c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -4610,6 +4610,32 @@ It is inspired by SPDY but is not interoperable with it.")
intends to be compatible with Avahi.")
(license license:expat)))
+(define-public go-github-com-macronut-go-tproxy
+ (package
+ (name "go-github-com-macronut-go-tproxy")
+ (version "0.0.0-20190726054950-ef7efd7f24ed")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FutureProtocolLab/go-tproxy")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jibsg0xhsn0h1jq4g9qd4nr58w43y8majlwfri9ffk2cbfrwqdr"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "example"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/macronut/go-tproxy"))
+ (home-page "https://github.com/FutureProtocolLab/go-tproxy")
+ (synopsis "Linux Transparent Proxy library")
+ (description
+ "Golang TProxy provides an easy to use wrapper for the Linux Transparent
+Proxy functionality.")
+ (license license:expat)))
+
(define-public go-github-com-mailru-easyjson
(package
(name "go-github-com-mailru-easyjson")