summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-07-25 10:47:42 +0100
committerSharlatan Hellseher <[email protected]>2024-07-25 21:00:57 +0100
commit04af4f6646ec4949b716240e3a8b8153b2e1cb42 (patch)
tree1aa150f2221dabd9b42ca2f70d4ab72c44cb070b /gnu/packages/golang-web.scm
parent162f716d74c53ce6b7ea885895bfb884dde5b48d (diff)
gnu: go-golang-org-x-oauth2: Move to golang-web.
* gnu/packages/golang.scm (go-golang-org-x-oauth2): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I60fd46f5c373ccdb00c78c978a840acfe9f489b1
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a9658cfbac..a9213f1be8 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3,9 +3,9 @@
;;; Copyright © 2018 Pierre Neidhardt <[email protected]>
;;; Copyright © 2018 Pierre-Antoine Rouby <[email protected]>
;;; Copyright © 2019 Vagrant Cascadian <[email protected]>
+;;; Copyright © 2019, 2020 Martin Becze <[email protected]>
;;; Copyright © 2020 Jack Hill <[email protected]>
;;; Copyright © 2020 Joseph LaFreniere <[email protected]>
-;;; Copyright © 2020 Martin Becze <[email protected]>
;;; Copyright © 2020 Nicolas Goaziou <[email protected]>
;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2020 Ryan Prior <[email protected]>
@@ -3224,6 +3224,33 @@ programming language.")
programming language, which supports draft-04, draft-06 and draft-07.")
(license license:asl2.0))))
+(define-public go-golang-org-x-oauth2
+ (package
+ (name "go-golang-org-x-oauth2")
+ (version "0.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/oauth2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pzpa9jqrfxxhxi1w7n5ljnvr9qfw42hzavz62fc9i6z9vk2466k"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "golang.org/x/oauth2"))
+ (propagated-inputs
+ (list go-cloud-google-com-go-compute-metadata
+ go-github-com-google-go-cmp))
+ (home-page "https://go.googlesource.com/oauth2")
+ (synopsis "Client implementation of the OAuth 2.0 spec")
+ (description
+ "This package contains a client implementation for OAuth 2.0
+ spec in Go.")
+ (license license:bsd-3)))
+
;; XXX: This repository has been archived by the owner on Feb 27, 2023. It is
;; now read-only and it is DEPRECATED.
(define-public go-gopkg-in-square-go-jose-v2