summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-vcs.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-05 23:49:41 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:51 +0000
commitbbcd2074f06779a33874ea57d97c8590a68e92b6 (patch)
tree359a8b7affa186d5a77e6f0502f4340198def95e /gnu/packages/golang-vcs.scm
parent4cf6d0f134da039410955b4f5152f6fa5728c781 (diff)
gnu: Add go-github-com-xanzy-go-gitlab.
* gnu/packages/golang-vcs.scm (go-github-com-xanzy-go-gitlab): New variable. Change-Id: Id59090f6642e01e223690b022e29e123a6bac03c
Diffstat (limited to 'gnu/packages/golang-vcs.scm')
-rw-r--r--gnu/packages/golang-vcs.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/golang-vcs.scm b/gnu/packages/golang-vcs.scm
index 1dd67125d5..b264b3ecaf 100644
--- a/gnu/packages/golang-vcs.scm
+++ b/gnu/packages/golang-vcs.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,7 +22,10 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
- #:use-module (gnu packages))
+ #:use-module (gnu packages)
+ #:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-web))
;;; Commentary:
;;;
@@ -33,6 +37,38 @@
;;; Libraries:
;;;
+(define-public go-github-com-xanzy-go-gitlab
+ (package
+ (name "go-github-com-xanzy-go-gitlab")
+ (version "0.114.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xanzy/go-gitlab")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "136iik1pqggdk2z3yz4wh5z05wp9sb6j1rpbf33bjn5djqxcxbbf"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xanzy/go-gitlab"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-google-go-querystring
+ go-github-com-hashicorp-go-cleanhttp
+ go-github-com-hashicorp-go-retryablehttp
+ go-golang-org-x-oauth2
+ go-golang-org-x-time))
+ (home-page "https://github.com/xanzy/go-gitlab")
+ (synopsis "GitLab Go SDK")
+ (description
+ "This package provides a GitLab API client enabling Go programs to
+interact with GitLab in a simple and uniform way.")
+ (license license:asl2.0)))
+
;;;
;;; Executables:
;;;