summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-maths.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-15 18:52:36 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:02 +0000
commit8917b837429cead11ec3403dd4b503d3cb859d2b (patch)
treea69f0fe80cbc6816b19fa8b359746c387a74440e /gnu/packages/golang-maths.scm
parent951eaefb8fb0f27fe5aeb2007f5914f263c6d8bd (diff)
gnu: go-github-com-montanaflynn-stats: Fix build.
* gnu/packages/golang-maths.scm (go-github-com-montanaflynn-stats) [arguments]<phases>: Add 'remove-examples. Change-Id: Ib07cd22ea3e7b1ae6fb20748a3458cd5bc913b9a
Diffstat (limited to 'gnu/packages/golang-maths.scm')
-rw-r--r--gnu/packages/golang-maths.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang-maths.scm b/gnu/packages/golang-maths.scm
index 6eefad5ecd..4d5515c82d 100644
--- a/gnu/packages/golang-maths.scm
+++ b/gnu/packages/golang-maths.scm
@@ -131,7 +131,13 @@ and GCC’s decimal extension.")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/montanaflynn/stats"))
+ #:import-path "github.com/montanaflynn/stats"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file-recursively "examples")))))))
(home-page "https://github.com/montanaflynn/stats")
(synopsis "Statistics library for Golang")
(description