summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-19 12:49:43 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:07 +0000
commite171d1a420a2b30856bc3239bb1e5e72524fda55 (patch)
tree84475357d70e4c8ff1b9b8aa3f972b0c3bcee93f /gnu/packages/golang-check.scm
parent6893dae7b84956aa1913f2ec249bb1235368241c (diff)
gnu: go-github-com-jacobsa-ogletest: Fix indentation.
* gnu/packages/golang-check.scm (go-github-com-jacobsa-ogletest): Fix indentation. Change-Id: I1439b691a61ccd5b796bbc9a50c9c88ed954823f
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm61
1 files changed, 30 insertions, 31 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 7143adf664..d571a09c07 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -761,38 +761,37 @@ Test for C++ and Google JS Test.")
(license license:asl2.0))))
(define-public go-github-com-jacobsa-ogletest
- (package
- (name "go-github-com-jacobsa-ogletest")
- (version "0.0.0-20170503003838-80d50a735a11")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jacobsa/ogletest")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1lbwbxzr75g65q07ry5k4kglxqs3ym7xkvqznzm55rm3qk76v83r"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/jacobsa/ogletest"
- ;; These tests should be made working
- #:tests? #f))
- (native-inputs
- (list go-github-com-jacobsa-oglematchers
- go-github-com-jacobsa-oglemock
- go-github-com-jacobsa-reqtrace
- go-golang-org-x-net))
- (home-page "https://github.com/jacobsa/ogletest")
- (synopsis "Expressive unit tests")
- (description
- "Package ogletest provides a framework for writing expressive unit tests. It
-integrates with the builtin testing package, so it works with the gotest
+ (package
+ (name "go-github-com-jacobsa-ogletest")
+ (version "0.0.0-20170503003838-80d50a735a11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/ogletest")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lbwbxzr75g65q07ry5k4kglxqs3ym7xkvqznzm55rm3qk76v83r"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jacobsa/ogletest"
+ ;; These tests should be made working
+ #:tests? #f))
+ (native-inputs
+ (list go-github-com-jacobsa-oglematchers
+ go-github-com-jacobsa-oglemock
+ go-github-com-jacobsa-reqtrace
+ go-golang-org-x-net))
+ (home-page "https://github.com/jacobsa/ogletest")
+ (synopsis "Expressive unit tests")
+ (description
+ "Package ogletest provides a framework for writing expressive unit tests.
+It integrates with the builtin testing package, so it works with the gotest
command. Unlike the testing package which offers only basic capabilities for
-signalling failures, it offers ways to express expectations and get nice failure
-messages automatically.")
- (license license:asl2.0)))
+signalling failures, it offers ways to express expectations and get nice
+failure messages automatically.")
+ (license license:asl2.0)))
(define-public go-github-com-jacobsa-reqtrace
(package