summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-20 07:51:06 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:11 +0000
commitc62dc12069185667e67aa6f7829829d764c79ac4 (patch)
tree42c5a90739e2011f47d4db9ba77d93815fdf4ff8 /gnu/packages/golang-check.scm
parent2cf9fb3bf72721cb9ca1c553d725c761b4e2748e (diff)
gnu: Add go-github-com-bitfield-gotestdox.
* gnu/packages/golang-check.scm (go-github-com-bitfield-gotestdox, go-testdox): New variables. Change-Id: If9d0964a6067a47dc75bc0af5741014b1002d8d0
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 37487e7bd9..cd5963f7e6 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -121,6 +121,36 @@ value and call @code{t.Fatal()} if the assertion fails.")
@end itemize")
(license license:expat)))
+(define-public go-github-com-bitfield-gotestdox
+ (package
+ (name "go-github-com-bitfield-gotestdox")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bitfield/gotestdox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kxj8igjm0wmq9nj3wns7nf95rx70xm327ra68d3ffh300rxg401"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/bitfield/gotestdox"))
+ (propagated-inputs
+ (list go-github-com-fatih-color
+ go-github-com-google-go-cmp
+ go-github-com-mattn-go-isatty
+ go-github-com-rogpeppe-go-internal
+ go-golang-org-x-text))
+ (home-page "https://github.com/bitfield/gotestdox")
+ (synopsis "Format Go test results as readable documentation")
+ (description
+ "This packages implements a functionality to run tests and report the
+results, converting test names WrittenInCamelCase into ordinary sentences.")
+ (license license:expat)))
+
(define-public go-github-com-caarlos0-testfs
(package
(name "go-github-com-caarlos0-testfs")
@@ -2104,6 +2134,20 @@ into @code{go-structlayout-pretty}.")))
(description "This package takes @code{go-structlayout}-like JSON and
prints an ASCII fraphic representing the memory layout.")))
+(define-public go-testdox
+ (package
+ (inherit go-github-com-bitfield-gotestdox)
+ (name "go-testdox")
+ (arguments
+ (list
+ #:install-source? #f
+ #:import-path "github.com/bitfield/gotestdox/cmd/gotestdox"
+ #:unpack-path "github.com/bitfield/gotestdox"))
+ (description
+ (string-append (package-description go-github-com-bitfield-gotestdox)
+ " This package provides an command line interface (CLI)
+tool."))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar