summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-01 15:44:39 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:43 +0000
commitbaba666a6f735d6855b6281042283ce525524236 (patch)
tree4439e7f7c0e73001f85f218fe711ab207c1adadb /gnu/packages/golang-check.scm
parente5bf6db0a029354d705cc12af1f9e582d2342cdd (diff)
gnu: Add go-github-com-ldez-tagliatelle.
* gnu/packages/golang-check.scm (go-github-com-ldez-tagliatelle): New variable. Change-Id: I78d19e9c1afa21ac126b76ee7ec0222d11c4ff9a
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 14a30317c9..be36e7503f 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1018,6 +1018,34 @@ differently.")
testing of time-sensitive code.")
(license license:expat)))
+(define-public go-github-com-ldez-tagliatelle
+ (package
+ (name "go-github-com-ldez-tagliatelle")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ldez/tagliatelle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s891pqzwivmhw7xfw0m8n8fcg90xiykcg808rr869iflbkdik9n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ldez/tagliatelle"))
+ (propagated-inputs
+ (list go-github-com-ettle-strcase
+ go-github-com-hashicorp-go-immutable-radix-v2
+ go-golang-org-x-tools))
+ (home-page "https://github.com/ldez/tagliatelle")
+ (synopsis "Struct tags handling linter for Golang")
+ (description
+ "This package implement a functionality for validating tags according to
+rules you define and fixing them according to the defined rules.")
+ (license license:asl2.0)))
+
(define-public go-github-com-maruel-panicparse
(package
(name "go-github-com-maruel-panicparse")