summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-15 15:45:40 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:01 +0000
commitad071544aea3e6c8644daaa6f52c0baadd877516 (patch)
treef6c50e6fd95f3b0ef44b29f52f5cf1d1fbf269a5 /gnu/packages/golang-check.scm
parent9bef96bdc0d683410350231b185d47fd58a37f45 (diff)
gnu: go-github-com-smartystreets-goconvey: Improve package style.
* gnu/packages/golang-check.scm (go-github-com-smartystreets-goconvey) [version]: Apply the same stile as produced by importer. [source]<commit>: Adjust accordingly. [arguments]: Use list style. [description]: Start from a new line. Change-Id: Ie89644cec96c775c5f19f9ecc3ffaa15fba432cb
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 956a2ede13..c2330ce9df 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1247,28 +1247,29 @@ execution when a test fails.")
(define-public go-github-com-smartystreets-goconvey
(package
(name "go-github-com-smartystreets-goconvey")
- (version "v1.8.1")
+ (version "1.8.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/smartystreets/goconvey")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "0s9s7yd4jfwgirnz46kw1sfhgcgsdzfxlca6q16i6ixaqczfaap9"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/smartystreets/goconvey"))
+ (list
+ #:import-path "github.com/smartystreets/goconvey"))
(propagated-inputs
(list go-github-com-jtolds-gls
go-github-com-smarty-assertions
go-golang-org-x-tools))
(home-page "https://github.com/smartystreets/goconvey")
(synopsis "Go testing tool with both a web and terminal user interface")
- (description "GoConvey is a testing tool for Go. It integrates with go
-test, can show test coverage and has a web user interface that will refresh
-automatically.")
+ (description
+ "GoConvey is a testing tool for Go. It integrates with go test, can show
+test coverage and has a web user interface that will refresh automatically.")
(license license:expat)))
(define-public go-github-com-smarty-assertions