summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-19 16:52:33 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:08 +0000
commita46595d8862db10ba74ddc80097b10637ab8446e (patch)
tree94a29fa7e716fa367bb91e81c8b4f6fbb1302bb0 /gnu/packages/golang-check.scm
parentfd0586d9c5aa936402cc4260c4cf7e5faacbe1ba (diff)
gnu: Add go-github-com-jarcoal-httpmock.
* gnu/packages/golang-check.scm (go-github-com-jarcoal-httpmock): New variable. Change-Id: I6b76a05a97f554af7f9d34aa4aa435a2ba77a3ec
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 812d59b286..37487e7bd9 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -828,6 +828,32 @@ failure messages automatically.")
"Package reqtrace contains a very simple request tracing framework.")
(license license:asl2.0)))
+(define-public go-github-com-jarcoal-httpmock
+ (package
+ (name "go-github-com-jarcoal-httpmock")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jarcoal/httpmock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xw73d59nl1jj18h2hp9vlgqmfvqk9bknzpimg4mjn13d4jzhqrf"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jarcoal/httpmock"))
+ (native-inputs
+ (list go-github-com-maxatome-go-testdeep))
+ (home-page "https://github.com/jarcoal/httpmock")
+ (synopsis "HTTP mocking for Golang")
+ (description
+ "Package httpmock provides tools for mocking HTTP responses. It
+implements exact URL and regexp matches.")
+ (license license:expat)))
+
(define-public go-github-com-jbenet-go-cienv
(package
(name "go-github-com-jbenet-go-cienv")