summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-29 20:41:42 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:37 +0000
commit9a1a5f174cd0bac045c186208dcee967b0da695a (patch)
tree48e2975435b9bb369fda61543611c17b9a27f3a8 /gnu/packages/golang-check.scm
parent11286f4b0d7b76cfad76831c240bc63c97865227 (diff)
gnu: go-github-com-maruel-panicparse: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-maruel-panicparse): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Ib11a56341d3c77bb87a1eef21956482df7e1b50d
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm51
1 files changed, 48 insertions, 3 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 611cd501ba..47990ec756 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -9,21 +9,21 @@
;;; Copyright © 2020 Joseph LaFreniere <[email protected]>
;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2020 Ryan Prior <[email protected]>
+;;; Copyright © 2020, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2021 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2021 Sarah Morgensen <[email protected]>
;;; Copyright © 2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2022 ( <[email protected]>
-;;; Copyright © 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2023 Benjamin <[email protected]>
;;; Copyright © 2023 Felix Lechner <[email protected]>
;;; Copyright © 2023 Fries <[email protected]>
;;; Copyright © 2023 Hilton Chain <[email protected]>
;;; Copyright © 2023 Katherine Cox-Buday <[email protected]>
+;;; Copyright © 2024 Artyom V. Poptsov <[email protected]>
;;; Copyright © 2024 Greg Hogan <[email protected]>
+;;; Copyright © 2024 Herman Rimm <[email protected]>
;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
;;; Copyright © 2024 Troy Figiel <[email protected]>
-;;; Copyright © 2024 Artyom V. Poptsov <[email protected]>
-;;; Copyright © 2024 Herman Rimm <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -936,6 +936,51 @@ Many times certain facilities are not available, or tests must run
differently.")
(license license:expat)))
+(define-public go-github-com-maruel-panicparse
+ (package
+ (name "go-github-com-maruel-panicparse")
+ (version "1.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/maruel/panicparse")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07hj3z47v4mzppi8r7ja20arh2kd0dih913xgb9ylapf7w5q98bn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/maruel/panicparse"
+ #:test-flags
+ #~(list "-skip"
+ (string-join
+ ;; Failed with panic.
+ (list "TestAugment"
+ "TestPanic"
+ "TestPanicweb"
+ "TestProcessTwoSnapshots"
+ "TestSnapshotHandler"
+ "TestSnapshotHandler_Err"
+ "TestSnapshotHandler_LargeMemory"
+ )
+ "|"))))
+ (native-inputs
+ (list go-github-com-google-go-cmp))
+ (propagated-inputs
+ (list go-github-com-mattn-go-colorable
+ go-github-com-mattn-go-isatty
+ go-github-com-mgutz-ansi
+ go-golang-org-x-sys))
+ (home-page "https://github.com/maruel/panicparse")
+ (synopsis "Toolkit for parsing Go stack traces")
+ (description
+ "This package provides a toolkit for parsing Go language panic stack
+traces. It simplifies the traces to make salient information more visible and
+aid debugging.")
+ (license license:asl2.0)))
+
(define-public go-github-com-marvinjwendt-testza
(package
(name "go-github-com-marvinjwendt-testza")