summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-23 13:06:01 +0000
committerSharlatan Hellseher <[email protected]>2025-01-24 22:52:20 +0000
commit60e1d11154cfa1e10509a8d66ec2191f42025586 (patch)
tree521ae554e98d7fc595bc1d1ff6e3d405f59a87fa /gnu/packages/golang-check.scm
parent7b287dd8adddb1e5792a8c1d8b79d74d0d8474e5 (diff)
gnu: go-github-com-golangplus-fmt: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-golangplus-fmt): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: If236c036b3922d82d88fd745bf81c94f9d4d2bc5
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 2eb6bc46b4..d0371aa915 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -666,6 +666,30 @@ programming language}. It integrates well with Go's built-in @code{testing}
package, but can be used in other contexts too.")
(license license:asl2.0)))
+(define-public go-github-com-golangplus-fmt
+ (package
+ (name "go-github-com-golangplus-fmt")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golangplus/fmt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07d5kxz0f8ss3v46y0c8jg02sagi0wlaaijhjzzp0r462jyzqii7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f ; failing with new Golang compiler.
+ #:import-path "github.com/golangplus/fmt"))
+ (home-page "https://github.com/golangplus/fmt")
+ (synopsis "Additions to Go's standard @code{fmt} package")
+ (description
+ "This package provides additions to Go's stdlib @code{fmt}.")
+ (license license:bsd-3)))
+
(define-public go-github-com-golangplus-testing
(package
(name "go-github-com-golangplus-testing")