summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorRoman Scherer <[email protected]>2024-12-29 13:14:29 +0100
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:44 +0000
commit395b3cf94102dcf558e41888c571b56580a9f087 (patch)
tree0220262109273ee015d2686e00625546a34caa96 /gnu/packages/golang-check.scm
parentbb451548f1f28db6d62bfb03f193e127a7de0215 (diff)
gnu: Add go-github-com-bool64-shared.
* gnu/packages/golang-check.scm (go-github-com-bool64-shared): New variable. Change-Id: Ib6b26619e2065e3a40ccae59f821aabffa2b00a0 Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index e51cf1bf90..88f2ff0d59 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -202,6 +202,33 @@ results, converting test names WrittenInCamelCase into ordinary sentences.")
for Golang projects via modular Makefiles and GitHub Actions.")
(license license:expat)))
+(define-public go-github-com-bool64-shared
+ (package
+ (name "go-github-com-bool64-shared")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bool64/shared")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "157k7vw9cq84i5yy8bab8n1dk2lc9cmz8kjjy710ic9lwridmnf8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/bool64/shared"))
+ (native-inputs
+ (list go-github-com-bool64-dev
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/bool64/shared")
+ (synopsis "Share variables between test helpers in Golang")
+ (description
+ "This package provides a contract to share variables between test helpers
+in Golang.")
+ (license license:expat)))
+
(define-public go-github-com-caarlos0-testfs
(package
(name "go-github-com-caarlos0-testfs")