summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-11 13:15:51 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:57 +0000
commit325085f7787cc65fe2052a5bea6977fcb505e327 (patch)
treed23324c0cc0cc2e4e23ba45cd99dfbee7fc6916c /gnu/packages/golang-check.scm
parent71c11df778fc7305a367923a1d0e5ee196961df8 (diff)
gnu: go-github-com-rubyist-tracerx: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-rubyist-tracerx): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Ie3791edb545221c42468293b1ac7e9a818c32662
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 89304e1e84..2eb6bc46b4 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1510,6 +1510,31 @@ original value once the test has been run.")
current goroutine's ID.")
(license license:asl2.0))))
+(define-public go-github-com-rubyist-tracerx
+ (package
+ (name "go-github-com-rubyist-tracerx")
+ (version "0.0.0-20170927163412-787959303086")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rubyist/tracerx")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xj5213r00zjhb7d2l6wlwv62g6mss50jwjpf7g8fk8djv3l29zz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/rubyist/tracerx"))
+ (home-page "https://github.com/rubyist/tracerx/")
+ (synopsis "Output tracing information in your Go app")
+ (description
+ "This package is a simple tracing application that logs messages
+depending on environment variables. It is very much inspired by git's
+GIT_TRACE mechanism.")
+ (license license:expat)))
+
(define-public go-github-com-sasha-s-go-deadlock
(package
(name "go-github-com-sasha-s-go-deadlock")