summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-14 11:33:05 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:56 +0000
commit26636d1fd21ecf184b4eaf1aeb8b6c909a7fa8a6 (patch)
tree6266ea19783b6da039681f9a06b7a47f6159fc04 /gnu/packages/golang-check.scm
parent4c0dfa28497e5a00b2c1c44837d8e9d35ce48a28 (diff)
gnu: Add go-github-com-icrowley-fake.
* gnu/packages/golang-check.scm (go-github-com-icrowley-fake): New variable. Change-Id: Ia3158c274a7e69f777f695c63bdb9e7c70cc6ae8
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 6030046da7..1ac15add6d 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -620,6 +620,33 @@ package).")
"This package provides a library to generate unified diffs.")
(license license:bsd-3)))
+(define-public go-github-com-icrowley-fake
+ (package
+ (name "go-github-com-icrowley-fake")
+ (version "0.0.0-20240710202011-f797eb4a99c0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/icrowley/fake")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zb2rdck6fwjw1ib7k6gm9d9mnsig4cr2807k7v5z6nwqka1pcw1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/icrowley/fake"))
+ (propagated-inputs
+ (list go-github-com-corpix-uarand))
+ (home-page "https://github.com/icrowley/fake")
+ (synopsis "Fake data generator for Golang")
+ (description
+ "Package fake is the fake data generatror for go (Golang), heavily
+inspired by forgery and @url{https://github.com/ffaker/ffaker,ffaker} Ruby
+gems.")
+ (license license:expat)))
+
(define-public go-github-com-jackc-pgmock
(package
(name "go-github-com-jackc-pgmock")