summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorRoman Scherer <[email protected]>2024-12-29 13:14:35 +0100
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:45 +0000
commit18ac047ca0f4572ab544341685dcd1ceb27c3e99 (patch)
tree2f61a0a0b496375e94e6fccb529804152c784b33 /gnu/packages/golang-check.scm
parent24c8a97c3cd024c8f76209a25d44e5f5aeaeae2b (diff)
gnu: Add go-github-com-swaggest-assertjson.
* gnu/packages/golang-check.scm (go-github-com-swaggest-assertjson): New variable. Change-Id: Ib679c647d68c03bcd941ec6b475cc0745c6dc236 Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 88f2ff0d59..c89cd5ee61 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1578,6 +1578,45 @@ Features include:
strings must or must not be sent to a given local UDP listener.")
(license license:expat)))
+(define-public go-github-com-swaggest-assertjson
+ (package
+ (name "go-github-com-swaggest-assertjson")
+ (version "1.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swaggest/assertjson")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0smxcs548dnchqqk4bys167xaawzz125qsvlvpa267fkhqrxk7f9"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/swaggest/assertjson"
+ #:test-flags #~(list "-skip" "TestEquals_message")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (for-each delete-file
+ (list "example_test.go"))))))))
+ (native-inputs
+ (list go-github-com-bool64-dev
+ go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-bool64-shared
+ go-github-com-iancoleman-orderedmap
+ go-github-com-yosuke-furukawa-json5
+ go-github-com-yudai-gojsondiff))
+ (home-page "https://github.com/swaggest/assertjson")
+ (synopsis "JSON equality assertions for Golang")
+ (description
+ "This package provides JSON equality assertions for Golang.")
+ (license license:expat)))
+
(define-public go-github-com-tdewolff-test
(package
(name "go-github-com-tdewolff-test")