summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-19 12:43:20 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:07 +0000
commit165053a02450c31b763b0e614bc65b101b634031 (patch)
tree41d8f2b069354c632c0da490295cea6fbd11e67b /gnu/packages/golang-check.scm
parentce306a9a09b03c521855ecc8f1e73009aa3013b1 (diff)
gnu: go-github-com-jacobsa-reqtrace: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-jacobsa-reqtrace): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: If331f4aa071ee810b3f5e286def7e181f1971f3d
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 161740b8e8..57614c0a18 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -796,6 +796,31 @@ signalling failures, it offers ways to express expectations and get nice failure
messages automatically.")
(license license:asl2.0))))
+(define-public go-github-com-jacobsa-reqtrace
+ (package
+ (name "go-github-com-jacobsa-reqtrace")
+ (version "0.0.0-20150505043853-245c9e0234cb")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/reqtrace")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zfyijig10896v42rvxka1n4wn6lijqz40y2281187l7mq8vv5jn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jacobsa/reqtrace"))
+ (propagated-inputs
+ (list go-golang-org-x-net))
+ (home-page "https://github.com/jacobsa/reqtrace")
+ (synopsis "Simple request tracing framework")
+ (description
+ "Package reqtrace contains a very simple request tracing framework.")
+ (license license:asl2.0)))
+
(define-public go-github-com-jbenet-go-cienv
(package
(name "go-github-com-jbenet-go-cienv")