summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-14 11:43:00 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:57 +0000
commit02c5fbeb93f378c77dbc0b9df51da5f2afdbe991 (patch)
tree5ce8df7c84b55ed31b435865fa691a1e8b310ecd /gnu/packages/golang-check.scm
parent26636d1fd21ecf184b4eaf1aeb8b6c909a7fa8a6 (diff)
gnu: Add go-github-com-jackc-fake.
* gnu/packages/golang-check.scm (go-github-com-jackc-fake): New variable. Change-Id: I744e09a6ba01c750e80e533ea3fe1663ad0fb93d
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 1ac15add6d..8293d5b6c0 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -647,6 +647,35 @@ inspired by forgery and @url{https://github.com/ffaker/ffaker,ffaker} Ruby
gems.")
(license license:expat)))
+(define-public go-github-com-jackc-fake
+ (package
+ (inherit go-github-com-icrowley-fake)
+ (name "go-github-com-jackc-fake")
+ (version "0.0.0-20150926172116-812a484cc733")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jackc/fake")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0f32qgzhx7pl3s0g4v916z21kfyh5v1dv28aakxisiw23936wf68"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Module name has not been changed after been forked upstream.
+ (substitute* (find-files "." "\\.go$")
+ (("github.com/icrowley/fake") "github.com/jackc/fake"))))))
+ (arguments
+ (list
+ #:import-path "github.com/jackc/fake"))
+ (home-page "https://github.com/jackc/fake")
+ (description
+ "This package is an alternative fork of @url{github.com/icrowley/fake}
+used in go-github-com-jackc-pgx.")
+ (license license:expat)))
+
(define-public go-github-com-jackc-pgmock
(package
(name "go-github-com-jackc-pgmock")