summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-14 11:04:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:41:56 +0000
commitda29c178926ec1a473006f64e6cc45d6060f47bc (patch)
tree163e665e5102a10a79be6cc587ac5932833374e0 /gnu/packages/golang-build.scm
parent01fd7f5d41dcde45186da6c81336a38ede0ea7fe (diff)
gnu: go-github-com-pkg-errors: Move to golang-build.
* gnu/packages/golang.scm (go-github-com-pkg-errors): Move from here ... * gnu/packages/golang-build.scm: ... to here. Change-Id: Ic91629d1832e559928b20567bd930783377b568c
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm36
1 files changed, 33 insertions, 3 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 4731f8b5ec..0df28a77ef 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -1,12 +1,12 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017-2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
+;;; Copyright © 2019, 2020 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2020 HiPhish <hiphish@posteo.de>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
-;;; Copyright © 2020 Vagrant Cascadian <vagrant@debian.org>
-;;; Copyright © 2020, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020, 2022, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -312,6 +312,36 @@ replace a file or symbolic link.")
1.1: Authentication and Security Services.")
(license license:bsd-3)))
+;; XXX: This repository has been archived by the owner on Dec 1, 2021. It is
+;; now read-only.
+(define-public go-github-com-pkg-errors
+ (package
+ (name "go-github-com-pkg-errors")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/errors")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1761pybhc2kqr6v5fm8faj08x9bql8427yqg6vnfv6nhrasx1mwq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Tests fail with a newer version of Golang (1.21) due to some API
+ ;; changes in how the module path is calculated which is not reflected
+ ;; in tests.
+ #:tests? #f
+ #:import-path "github.com/pkg/errors"))
+ (home-page "https://github.com/pkg/errors")
+ (synopsis "Go error handling primitives")
+ (description
+ "This package provides @code{error}, which offers simple error handling
+primitives in Go.")
+ (license license:bsd-2)))
+
(define-public go-github-com-yuin-goldmark
(package
(name "go-github-com-yuin-goldmark")