summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-19 20:54:21 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:09 +0000
commit8fafe6d8b6d50cefac2540440c20ffba50e29e2d (patch)
treef34e9214e97509c031487e572fd2292376536262 /gnu/packages/golang-build.scm
parentc33de366f8aa0fe069ef8b04dec1c3333162706e (diff)
gnu: go-golang-org-x-text: Simplify.
* gnu/packages/golang-build.scm (go-golang-org-x-text): [arguments] <skip-build?>: Set to #t, as no go files in project's root. <phases>: Use default 'check. [native-inputs]: Add go-golang-org-x-mod-bootstrap, go-golang-org-x-sync-bootstrap, and go-golang-org-x-tools-bootstrap. Change-Id: Ib4e55e622554d79a8d03abfc52ced0a5eb516d85
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm34
1 files changed, 6 insertions, 28 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 7b962f0948..b4657a1355 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -960,35 +960,13 @@ terminals, as commonly found on Unix systems.")
(build-system go-build-system)
(arguments
(list
- #:import-path "golang.org/x/text"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v"
- "./cases/..."
- ;; cmd - cycle with go-golang-org-x-tools
- "./collate/..."
- "./currency/..."
- "./date/..."
- "./encoding/..."
- "./feature/..."
- "./internal/..."
- "./language/..."
- ;; message - cycle with go-golang-org-x-tools
- "./number/..."
- "./runes/..."
- "./search/..."
- "./secure/..."
- "./transform/..."
- "./unicode/..."
- "./width/..."))))))))
+ #:skip-build? #t
+ #:import-path "golang.org/x/text"))
(home-page "https://go.googlesource.com/text")
+ (native-inputs
+ (list go-golang-org-x-mod-bootstrap
+ go-golang-org-x-sync-bootstrap
+ go-golang-org-x-tools-bootstrap))
(synopsis "Supplemental Go text processing libraries")
(description
"This package provides supplemental Go libraries for text