summaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorMark H Weaver <[email protected]>2016-05-11 13:37:47 -0400
committerMark H Weaver <[email protected]>2016-05-11 13:37:47 -0400
commit9f5e79675367aedd6be89e07edbc08a6e3695fab (patch)
tree2679dfc572b7173ba6fe52611047a47283af119d /gnu/packages/gnustep.scm
parente2b89203db6c2056c9658be40ab1be471769d9eb (diff)
parentcf60e76a9503156a8c1047fa446525b28842f7e8 (diff)
Merge branch 'master' into gnome-updates
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index f4a2b266a3..31fca5b504 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -24,6 +24,7 @@
#:use-module (guix licenses)
#:use-module (gnu packages xorg)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages autotools)
#:use-module (gnu packages glib)
@@ -216,3 +217,31 @@ on.")
a dockable tile. It features multiple language support, 24h or 12h time
display, and can run a user-specified program on mouse click.")
(license gpl2+)))
+
+(define-public wmfire
+ (package
+ (name "wmfire")
+ (version "1.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.improbability.net/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gtk+" ,gtk+-2)
+ ("libgtop" ,libgtop)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.improbability.net/")
+ (synopsis "Display flames to represent CPU usage, memory usage, etc.")
+ (description
+ "wmfire is an applet for Window Maker that can monitor the average cpu
+load, or individual cpu load on SMP computers. Additionally it can monitor the
+memory, network load, a file or just be set to show a pretty flame. On
+entering the dock a burning spot replaces the cursor, and after two seconds
+symbols to represent the current monitor are \"burnt\" onscreen. The flame
+colour can also be changed.")
+ (license gpl2+)))