summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-01-25 23:36:11 -0500
committerMaxim Cournoyer <[email protected]>2022-01-25 23:48:37 -0500
commit0d41fe4855588fb659b8adafe215d5573517a79b (patch)
tree38b274bd03375f4fa5b7d3a9fb3f64a19786bef2 /gnu/packages/gcc.scm
parent7c57821c68d199ad56a8ed750b36eccc7ef238dd (diff)
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
Merge branch 'staging' into core-updates.
With "conflicts" resolved in (mostly in favor of master/staging): gnu/packages/admin.scm gnu/packages/gnuzilla.scm gnu/packages/gtk.scm gnu/packages/kerberos.scm gnu/packages/linux.scm guix/lint.scm
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm31
1 files changed, 29 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index f526680f56..efa0baeaa1 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -525,6 +525,27 @@ Go. It also includes runtime support libraries for these languages.")
,@(package-inputs gcc-4.7)))))
+(define %gcc-7.5-x86_64-micro-architectures
+ ;; Suitable '-march' values for GCC 7.5 (info "(gcc) x86 Options").
+ '("core2" "nehalem" "westmere" "sandybridge" "ivybridge"
+ "haswell" "broadwell" "skylake" "bonnell" "silvermont"
+ "knl" "skylake-avx512"
+
+ "k8" "k8-sse3" "barcelona"
+ "bdver1" "bdver2" "bdver3" "bdver4"
+ "znver1"
+ "btver1" "btver2" "geode"))
+
+(define %gcc-10-x86_64-micro-architectures
+ ;; Suitable '-march' values for GCC 10.
+ (append %gcc-7.5-x86_64-micro-architectures
+ '("goldmont" "goldmont-plus" "tremont"
+ "knm" "cannonlake" "icelake-client" "icelake-server"
+ "cascadelake" "cooperlake" "tigerlake"
+
+ "znver2" "znver3")))
+
+
(define-public gcc-7
(package
(inherit gcc-6)
@@ -542,7 +563,10 @@ Go. It also includes runtime support libraries for these languages.")
(description
"GCC is the GNU Compiler Collection. It provides compiler front-ends
for several languages, including C, C++, Objective-C, Fortran, Ada, and Go.
-It also includes runtime support libraries for these languages.")))
+It also includes runtime support libraries for these languages.")
+ (properties
+ `((compiler-cpu-architectures
+ ("x86_64" ,@%gcc-7.5-x86_64-micro-architectures))))))
(define-public gcc-8
(package
@@ -592,7 +616,10 @@ It also includes runtime support libraries for these languages.")))
(patches (search-patches "gcc-9-strmov-store-file-names.patch"
"gcc-5.0-libvtv-runpath.patch"))
(modules '((guix build utils)))
- (snippet gcc-canadian-cross-objdump-snippet)))))
+ (snippet gcc-canadian-cross-objdump-snippet)))
+ (properties
+ `((compiler-cpu-architectures
+ ("x86_64" ,@%gcc-10-x86_64-micro-architectures))))))
(define-public gcc-11
(package