summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorChristopher Baines <[email protected]>2023-03-02 10:37:28 +0000
committerChristopher Baines <[email protected]>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/firmware.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index aac1b5bf73..a876aa727a 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -456,6 +456,13 @@ provide OpenFirmware functionality on top of an already running system.")
(inherit base)
(arguments
(substitute-keyword-arguments (package-arguments base)
+ ((#:system system (%current-system))
+ (if (string-prefix? "aarch64-linux" (or (%current-system)
+ (%current-target-system)))
+ "armhf-linux"
+ system))
+ ;; No need to cross-compile, package produces reproducible firmware.
+ ((#:target _ #f) #f)
((#:phases phases)
#~(modify-phases #$phases
(add-after 'install 'rename-executable
@@ -569,6 +576,7 @@ executing in M-mode.")
(arguments
(list
#:tests? #f ;no tests
+ #:target #f ; Package produces firmware.
#:make-flags
;; If EXTRAVERSION is not set the build system will embed the current
;; date in binaries. Use this opportunity to personalize as recommended
@@ -740,6 +748,7 @@ coreboot.")
"HOSTCC=gcc")
#:parallel-build? #f
#:tests? #f ;no tests
+ #:target #f ; Package produces firmware.
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'build-reproducibly