summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2025-01-26 19:31:50 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2025-01-26 20:58:35 +0100
commitf5d28f9db90b90fe3297d91b36b918335fd18cea (patch)
treedf6239b6e37adeffc96507735a48eace5fa0d7a0 /gnu/packages/emacs-xyz.scm
parent5af119587d9dd6b620fea3ff08404245efac0204 (diff)
gnu: emacs-font-lock-studio: Update to 0.0.9.
* gnu/packages/emacs-xyz.scm (emacs-font-lock-studio): Update to 0.0.9. Change-Id: I5f8389dcb2bbec809e174fd44c4e25e1c8751d0f
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5dacc05c66..ad1861b73c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5677,25 +5677,23 @@ calculated based on how well you remembered the contents of the card.")
(license license:gpl3+))))
(define-public emacs-font-lock-studio
- (let ((commit "12c35967b31233e06946c70627aa3152dacfe261")
- (revision "1"))
- (package
- (name "emacs-font-lock-studio")
- (version (git-version "0.0.7" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Lindydancer/font-lock-studio")
- (commit "12c35967b31233e06946c70627aa3152dacfe261")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0q0s6f5vi3sfifj7vq2nnsmgyyivp1sd3idk32858md5ri71qif0"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/Lindydancer/font-lock-studio")
- (synopsis "Interactive debugger for Font Lock keywords")
- (description
- "Font Lock Studio is an interactive debugger for Emacs syntax highlighting
+ (package
+ (name "emacs-font-lock-studio")
+ (version "0.0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lindydancer/font-lock-studio")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ssa62qm3zv0l9adz0bpi4iaixbi788ihh1qy5n41h6jzcjig4k4"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Lindydancer/font-lock-studio")
+ (synopsis "Interactive debugger for Font Lock keywords")
+ (description
+ "Font Lock Studio is an interactive debugger for Emacs syntax highlighting
rules, also called Font Lock keywords. It can @emph{single-step} Font Lock
keywords -- matchers, highlights, and anchored rules, to see what happens when
a buffer is fontified. Breakpoints can be set on or inside rules. When
@@ -5703,7 +5701,7 @@ inside a rule, matches are visualized using a palette of background colors.
The explainer can describe a rule in plain-text English. Finally, tight
integration with Edebug allows stepping into Lisp expressions that are part of
the Font Lock keywords.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-fontaine
(package