summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorMark H Weaver <[email protected]>2015-04-17 22:06:05 -0400
committerMark H Weaver <[email protected]>2015-04-17 22:06:05 -0400
commit334345d9db53326fa062298e2372d6c33123949a (patch)
tree50774c171f1a348bd7de8e9a447bad2a14a9dffb /gnu/packages/elf.scm
parent8d7dc5d9dbf009009d33e21598f92c4685965cd5 (diff)
parent09dd019490e4a269b0a2d9512a07688f8ee657d3 (diff)
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 540478c075..cb456af195 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <[email protected]>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <[email protected]>
;;; Copyright © 2014, 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2015 Andreas Enge <[email protected]>
;;;
@@ -38,7 +38,9 @@
version "/elfutils-" version ".tar.bz2"))
(sha256
(base32
- "0w50szymyqvx8g0vkwrvnv17grqxva6x1z9dm9m3i99zg2hr232p"))))
+ "0w50szymyqvx8g0vkwrvnv17grqxva6x1z9dm9m3i99zg2hr232p"))
+ (patches
+ (list (search-patch "elfutils-tests-ptrace.patch")))))
(build-system gnu-build-system)
;; Separate programs because that's usually not what elfutils users want,
@@ -46,6 +48,13 @@
(outputs '("out" ; libelf.so, elfutils/*.h, etc.
"bin")) ; ld, nm, objdump, etc.
+ (arguments
+ ;; Programs don't have libelf.so in their RUNPATH and libraries don't
+ ;; know where to find each other.
+ `(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+
(native-inputs `(("m4" ,m4)))
(inputs `(("zlib" ,zlib)))
(home-page "https://fedorahosted.org/elfutils/")