summaryrefslogtreecommitdiff
path: root/gnu/packages/dunst.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
committerMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
commit1a5302435ff0d2822b823f5a6fe01faa7a85c629 (patch)
treeac7810c88b560532f22d2bab2e59609cd7305c21 /gnu/packages/dunst.scm
parent3ff2ac4980dacf10087e4b42bd9fbc490591900c (diff)
parent070b8a893febd6e7d8b2b7c8c4dcebacf7845aa9 (diff)
Merge branch 'master' into staging.
With "conflicts" solved (all in favor of master except git) in: gnu/local.mk gnu/packages/databases.scm gnu/packages/glib.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/linux.scm gnu/packages/machine-learning.scm gnu/packages/networking.scm gnu/packages/polkit.scm gnu/packages/pulseaudio.scm gnu/packages/rpc.scm gnu/packages/rust.scm gnu/packages/version-control.scm gnu/packages/w3m.scm
Diffstat (limited to 'gnu/packages/dunst.scm')
-rw-r--r--gnu/packages/dunst.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
index ce2c04bac6..998470e411 100644
--- a/gnu/packages/dunst.scm
+++ b/gnu/packages/dunst.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Efraim Flashner <[email protected]>
;;; Copyright © 2020 Brice Waegeneire <[email protected]>
;;; Copyright © 2021 Alexandru-Sergiu Marton <[email protected]>
+;;; Copyright © 2021 Guillaume Le Vaillant <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,16 +39,16 @@
(define-public dunst
(package
(name "dunst")
- (version "1.6.1")
+ (version "1.7.3")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/dunst-project/dunst")
- (commit (string-append "v" version))))
+ (url "https://github.com/dunst-project/dunst")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0lga1kj2vjbj9g9rl93nivngjmk5fkxdxwal8w96x9whwk9jvdga"))))
+ "1ra0ii805w3rrs0qqbjxzl6i79ksz42lnvbglw18h4igkza21kzj"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -62,22 +63,21 @@
#:phases (modify-phases %standard-phases
(delete 'configure))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("perl" ,perl) ; for pod2man
- ("which" ,which)))
+ (list pkg-config perl ; for pod2man
+ which))
(inputs
- `(("dbus" ,dbus)
- ("gdk-pixbuf" ,gdk-pixbuf+svg) ; for svg support
- ("glib" ,glib)
- ("cairo" ,cairo)
- ("pango" ,pango)
- ("libnotify" ,libnotify) ; for dunstify
- ("libx11" ,libx11)
- ("libxscrnsaver" ,libxscrnsaver)
- ("libxinerama" ,libxinerama)
- ("libxrandr" ,libxrandr)
- ("libxdg-basedir" ,libxdg-basedir)
- ("wayland" ,wayland))) ; for wayland support
+ (list dbus
+ librsvg ; for svg support
+ glib
+ cairo
+ pango
+ libnotify ; for dunstify
+ libx11
+ libxscrnsaver
+ libxinerama
+ libxrandr
+ libxdg-basedir
+ wayland)) ; for wayland support
(home-page "https://dunst-project.org/")
(synopsis "Customizable and lightweight notification daemon")
(description