summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-01-25 23:36:11 -0500
committerMaxim Cournoyer <[email protected]>2022-01-25 23:48:37 -0500
commit0d41fe4855588fb659b8adafe215d5573517a79b (patch)
tree38b274bd03375f4fa5b7d3a9fb3f64a19786bef2 /gnu/packages/crypto.scm
parent7c57821c68d199ad56a8ed750b36eccc7ef238dd (diff)
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
Merge branch 'staging' into core-updates.
With "conflicts" resolved in (mostly in favor of master/staging): gnu/packages/admin.scm gnu/packages/gnuzilla.scm gnu/packages/gtk.scm gnu/packages/kerberos.scm gnu/packages/linux.scm guix/lint.scm
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm37
1 files changed, 24 insertions, 13 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 4826b3851c..f07be01c97 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -383,18 +383,29 @@ the wrong hands.")
"$(LNS) "))))))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (delete 'configure)) ; no configure script
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- "RPATH=-Wl,-rpath,$(DESTDIR)$(LIBDIR)"
- (string-append "DESTDIR="
- (assoc-ref %outputs "out"))
- "INCLUDEDIR=/include"
- "LIBDIR=/lib"
- "MANDIR=/share/man"
- "SHAREDIR=/share/keyutils"
- "NO_ARLIB=1") ; omit static libraries
- #:test-target "test"))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ ;; "NO_ARLIB=1" would cleanly disable static libraries.
+ "RPATH=-Wl,-rpath,$(DESTDIR)$(LIBDIR)"
+ (string-append "DESTDIR=" #$output)
+ "INCLUDEDIR=/include"
+ "LIBDIR=/lib"
+ "MANDIR=/share/man"
+ "SHAREDIR=/share/keyutils")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-after 'install 'install:static
+ (lambda _
+ (with-directory-excursion #$output
+ (for-each (lambda (file)
+ (let ((target (string-append #$output:static
+ "/" file)))
+ (format #t "~a -> ~a\n" file target)
+ (mkdir-p (dirname target))
+ (rename-file file target)))
+ (find-files "lib" "\\.a$"))))))
+ #:test-target "test"))
(inputs
(list mit-krb5))
(home-page "https://people.redhat.com/dhowells/keyutils/")
@@ -403,7 +414,7 @@ the wrong hands.")
"Keyutils is a set of utilities for managing the key retention facility in
the Linux kernel, which can be used by file systems, block devices, and more to
gain and retain the authorization and encryption keys required to perform
-secure operations. ")
+secure operations.")
(license (list license:lgpl2.1+ ; the files keyutils.*
license:gpl2+)))) ; the rest