summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-08-11 22:15:22 +0200
committerMarius Bakke <[email protected]>2022-08-11 22:15:22 +0200
commitb50eaa67642ebc25e9c896f2e700c08610e0a5da (patch)
treee3358208e17a836c2e3cdb3125f815a2ab35c2b8 /gnu/packages/code.scm
parent7b69cd07408bf64fff026e4597920a90259e3205 (diff)
parent99b73f60415b282f2be39134f385cbda4840c336 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 64040270eb..96736aac84 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -914,8 +914,7 @@ extensions over the standard utility.")
(("test_command \"cc -Wall -Wextra -o source.out source.c\"" all)
"test_command \"gcc -Wall -Wextra -o source.out source.c\"")))))
(build-system gnu-build-system)
- (inputs
- `(("python" ,python-wrapper)))
+ (inputs (list python-wrapper))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1067,7 +1066,7 @@ Using cscope, you can easily search for where symbols are used and defined.")
"Xenon is a monitoring tool based on Radon. It monitors code complexity.
Ideally, @code{xenon} is run every time code is committed. Through command
line options, various thresholds can be set for the complexity of code. It
-will fail (i.e. it will exit with a non-zero exit code) when any of these
+will fail (i.e., it will exit with a non-zero exit code) when any of these
requirements is not met.")
(license license:expat)))