summaryrefslogtreecommitdiff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2022-06-08 14:46:24 +0200
committerLudovic Courtès <[email protected]>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/certs.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 28c2f84f98..d410b05860 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <[email protected]>
;;; Copyright © 2015 Mark H Weaver <[email protected]>
-;;; Copyright © 2016, 2017, 2021 Ludovic Courtès <[email protected]>
+;;; Copyright © 2016-2017, 2021-2022 Ludovic Courtès <[email protected]>
;;; Copyright © 2017 Leo Famulari <[email protected]>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2021 Maxim Cournoyer <[email protected]>
@@ -169,7 +169,12 @@ that was originally contributed to Debian.")
'(set-paths install-locale unpack))
(add-after 'unpack 'install
(lambda _
- (let ((certsdir (string-append %output "/etc/ssl/certs/")))
+ ;; TODO: On the next rebuild cycle, remove references to
+ ;; '%output' and '%outputs'.
+ (let ((certsdir (string-append ,(if (%current-target-system)
+ '(assoc-ref %outputs "out")
+ '%output)
+ "/etc/ssl/certs/")))
(with-directory-excursion "nss/lib/ckfw/builtins/"
(unless (file-exists? "blacklist.txt")
(call-with-output-file "blacklist.txt" (const #t)))