summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-22 20:22:19 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:42:16 +0000
commit6dd9a1ae130218b488f7209b7c4aea37b9e3b561 (patch)
tree826f514246dd6a784b2804dd92011b88daa99e76 /gnu/packages/calendar.scm
parent24da6bb4a7ff79927a2b36d37cd4024985f530c8 (diff)
gnu: hebcal: Fix indentation.
* gnu/packages/calendar.scm (hebcal): Fix indentation. Change-Id: If460d109e3906c5395be3848d48011ede767be4c
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm80
1 files changed, 39 insertions, 41 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 32493b0336..c4a1274ac3 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -437,46 +437,44 @@ configured to show the current time in different timezones.")
(license license:bsd-3))))
(define-public hebcal
- (package
- (name "hebcal")
- (version "5.8.7")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hebcal/hebcal")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1a1b9jip1ha6bzv6xg9fx47q167yzgbxjvrp5zngv175nzl9427j"))))
- (build-system go-build-system)
- (arguments
- (list
- #:install-source? #f
- #:import-path "github.com/hebcal/hebcal"
- #:phases
- #~(modify-phases %standard-phases
- ;; taken from Makefile
- (add-after 'unpack 'set-defautl-city
- (lambda* (#:key import-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" import-path)
- (with-output-to-file "dcity.go"
- (lambda ()
- (format #t "package main~%var defaultCity = ~s~%"
- "Paris")))))))))
- (inputs
- (list go-github-com-hebcal-hebcal-go
- go-github-com-pborman-getopt-v2))
- (synopsis "Perpetual Jewish Calendar program")
- (description
- "Hebcal is a program for converting between Hebrew and Gregorian
-dates, and generating lists of Jewish holidays for a given year.
-Shabbat, holiday candle lighting, and havdalah times are approximated
-using your location.
+ (package
+ (name "hebcal")
+ (version "5.8.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hebcal/hebcal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a1b9jip1ha6bzv6xg9fx47q167yzgbxjvrp5zngv175nzl9427j"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:install-source? #f
+ #:import-path "github.com/hebcal/hebcal"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; taken from Makefile
+ (add-after 'unpack 'set-defautl-city
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (with-output-to-file "dcity.go"
+ (lambda ()
+ (format #t "package main~%var defaultCity = ~s~%"
+ "Paris")))))))))
+ (inputs
+ (list go-github-com-hebcal-hebcal-go
+ go-github-com-pborman-getopt-v2))
+ (home-page "https://github.com/hebcal/hebcal")
+ (synopsis "Perpetual Jewish Calendar program")
+ (description
+ "Hebcal is a program for converting between Hebrew and Gregorian dates,
+and generating lists of Jewish holidays for a given year. Shabbat, holiday
+candle lighting, and havdalah times are approximated using your location.
-It can also show daily prayer times, the weekly Torah reading, and
-the daily leaf of Talmud. The program can help with counting of the
-Omer or with calculation of Hebrew yahrzeits, birthdays, or
-anniversaries.")
- (home-page "https://github.com/hebcal/hebcal")
+It can also show daily prayer times, the weekly Torah reading, and the daily
+leaf of Talmud. The program can help with counting of the Omer or with
+calculation of Hebrew yahrzeits, birthdays, or anniversaries.")
(license license:gpl2+)))