summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-14 15:35:50 +0000
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:55 +0100
commit332481ce58d0de7fecb5de8fcb36da943d4c2fc7 (patch)
tree8f73e2b632927efbd914490e95ed083cca20865f /gnu/packages/astronomy.scm
parent530fdf80bcb7daeef55fad1c750d4d9f31bc26ea (diff)
gnu: python-astroplan: Adjust inputs.
* gnu/packages/astronomy.scm (python-astroplan) [propagated-inputs]: Remove python-six. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I6a126ccb800e6bd82ecb1144367bed73d3548caa
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4c66e9c5e8..6a2a547321 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3591,17 +3591,18 @@ celestial-to-terrestrial coordinate transformations.")
(lambda _
(setenv "HOME" "/tmp")
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list python-pytest-astropy
+ python-pytest-mpl
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-astropy
python-astroquery
python-matplotlib
python-numpy
- python-pytz
- python-six))
- (native-inputs
- (list python-pytest-astropy
- python-pytest-mpl
- python-setuptools-scm))
+ python-pytz))
(home-page "https://github.com/astropy/astroplan")
(synopsis "Observation planning package for astronomers")
(description