summaryrefslogtreecommitdiff
path: root/gnu/packages/accessibility.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-09-27 14:24:37 -0400
committerMaxim Cournoyer <[email protected]>2022-09-27 14:27:28 -0400
commit3c6e220d8100281074c414a43c1efe9a01b53771 (patch)
treedc5d47fbbac3842d0da893adcd398dea10c1e681 /gnu/packages/accessibility.scm
parent08473753a0ebafef22c0894d846e3b42fd6be2a2 (diff)
parent62048ff9fcfbe3fc790a7207fc5f6f3e0476a02a (diff)
Merge branch 'master' into staging.
With resolved conflicts in: gnu/local.mk gnu/packages/crates-io.scm
Diffstat (limited to 'gnu/packages/accessibility.scm')
-rw-r--r--gnu/packages/accessibility.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 22e70b737a..499d79b8c8 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018, 2021, 2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Andrew Miloradovsky <[email protected]>
;;; Copyright © 2020 Efraim Flashner <[email protected]>
+;;; Copyright © 2022 Hunter Jozwiak <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system meson)
#:use-module (gnu packages)
#:use-module (gnu packages lisp)
#:use-module (gnu packages ocaml)
@@ -316,3 +318,34 @@ works with every X Window System based GUI (depends only on libX11); or as an
assistant for graphic designers, who need to select individual pixels.")
;; Licensed either under Expat or GPLv2+.
(license (list license:expat license:gpl2+))))
+
+(define-public espeakup
+ (package
+ (name "espeakup")
+ (version "0.90")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linux-speakup/espeakup")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lmjwafvfxy07zn18v3dzjwwpnid2xffgvy2dzlwkbns8gb60ds2"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list espeak-ng alsa-lib))
+ (license license:gpl3+)
+ (synopsis "Bridge for espeak and speakup")
+ (description
+ "Espeakup is a bridge between the speakup driver implemented in
+the Linux kernel and the espeak-ng text to speach synthesizer.
+In order for this package to work, you need to have the following
+kernel modules built:
+@itemize @bullet
+@item
+CONFIG_SPEAKUP=m
+@item
+CONFIG_SPEAKUP_SOFT=m
+@end itemize")
+ (home-page "ttps://github.com/linux-speakup/espeakup")))