summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-03-12 14:37:03 +0200
committerEfraim Flashner <[email protected]>2024-03-12 15:33:50 +0200
commitd7e092719a4e0e168df56c03076a87c0e32692e5 (patch)
tree97645a3bd6e852cb6858e47fe3cce8a8d4b947a1
parent30a8de0bcdadfb55cbcaa34760527c1b767808c7 (diff)
gnu: ruby-stackprof: Skip test known to fail.
* gnu/packages/ruby.scm (ruby-stackprof)[arguments]: Skip another test which is known to fail. Change-Id: Ie261864cc19eba881377b88c07b6402c60a22423
-rw-r--r--gnu/packages/ruby.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9a28ecf9f5..1020412847 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <[email protected]>
;;; Copyright © 2017 Nikita <[email protected]>
;;; Copyright © 2017, 2019-2022 Marius Bakke <[email protected]>
-;;; Copyright © 2017-2023 Efraim Flashner <[email protected]>
+;;; Copyright © 2017-2024 Efraim Flashner <[email protected]>
;;; Copyright © 2017, 2018, 2020, 2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2017 Clément Lassieur <[email protected]>
;;; Copyright © 2017, 2018, 2019 Christopher Baines <[email protected]>
@@ -9875,7 +9875,10 @@ navigation capabilities to @code{pry}, using @code{byebug}.")
(("def test_(cputime)" _ name)
(string-append "def skip_" name))
;; This test often fails
- (("def test_gc") "def skip_test_gc"))))
+ (("def test_gc") "def skip_test_gc")
+ ;; This test is known to fail on 32-bit systems.
+ ;; /gnu/store/w8y8wm82by1cnp33n5vy976wbrns9jys-stackprof-0.2.26.gem
+ (("def test_raw") "def skip_test_raw"))))
(add-before 'check 'build-tests
(lambda _
(invoke "rake" "compile")))