summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-28 18:17:49 +0800
committer宋文武 <[email protected]>2025-01-31 16:39:25 +0800
commitbbae86ea13f7c1cac8d5986077b9a75829dccadf (patch)
tree1eade874db4cab1102f4264e3b496b2fd8bde614
parent427e7f713e23130a0ffcdaab91f4f4d3bf144569 (diff)
gnu: libxt: Update to 1.3.1.
* gnu/packages/patches/libxt-guix-search-paths.patch: Adjust patch. * gnu/packages/xorg.scm (libxt): Update to 1.3.1. Change-Id: Ife5b761766c73a63413b5397286fffbd5e3e90a4
-rw-r--r--gnu/packages/patches/libxt-guix-search-paths.patch17
-rw-r--r--gnu/packages/xorg.scm6
2 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/patches/libxt-guix-search-paths.patch b/gnu/packages/patches/libxt-guix-search-paths.patch
index 61022d232a..174e68d45c 100644
--- a/gnu/packages/patches/libxt-guix-search-paths.patch
+++ b/gnu/packages/patches/libxt-guix-search-paths.patch
@@ -1,12 +1,12 @@
diff --git a/src/Intrinsic.c b/src/Intrinsic.c
--- a/src/Intrinsic.c
+++ b/src/Intrinsic.c
-@@ -1345,21 +1345,99 @@ FillInLangSubs(Substitution subs, XtPerDisplay pd)
+@@ -1310,21 +1310,98 @@ FillInLangSubs(Substitution subs, XtPerD
}
/*
- * default path used if environment variable XFILESEARCHPATH
-- * is not defined. Also substitued for %D.
+- * is not defined. Also substituted for %D.
- * The exact value should be documented in the implementation
- * notes for any Xt implementation.
+ Return the default search path for the function
@@ -65,11 +65,6 @@ diff --git a/src/Intrinsic.c b/src/Intrinsic.c
+ bytesAllocd += SIZEOF_STEMS;
+ bytesAllocd += 6 * (1 + strlen (guix_profile));
+ }
-
-- return xfilesearchpath;
--#else
-- return XFILESEARCHPATHDEFAULT;
--#endif
+ if (home != NULL)
+ {
+ bytesAllocd += SIZEOF_STEMS;
@@ -107,12 +102,16 @@ diff --git a/src/Intrinsic.c b/src/Intrinsic.c
+
+ /* Remove final : */
+ path[strlen(path) - 1] = '\0';
-+
+
+- return xfilesearchpath;
+-#else
+- return XFILESEARCHPATHDEFAULT;
+-#endif
+ return path;
}
-@@ -1388,7 +1466,7 @@ XtResolvePathname(Display *dpy,
+@@ -1353,7 +1430,7 @@ XtResolvePathname(Display *dpy,
{
XtPerDisplay pd;
static const char *defaultPath = NULL;
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 833251a6a3..b4e97f4cef 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5446,17 +5446,17 @@ Wayland.")
(define-public libxt
(package
(name "libxt")
- (version "1.2.1")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/lib/libXt-"
version
- ".tar.bz2"))
+ ".tar.xz"))
(sha256
(base32
- "0q1x7842r8rcn2m0q4q9f69h4qa097fyizs8brzx5ns62s7w1737"))
+ "120jjd6l7fjdxy5myrc1dmc0cwpqa18a97hrbg0d9x146frp99z0"))
(patches (search-patches "libxt-guix-search-paths.patch"))))
(build-system gnu-build-system)
(outputs '("out"