summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-28 18:39:09 +0800
committer宋文武 <[email protected]>2025-01-31 16:39:26 +0800
commit9507c3ff5271da943028657e5070d0b2fa4ce663 (patch)
tree5a09c68a0b505b64cf5f67482695df0d46fb5cbb
parentad8805034d74a79fb5b21d4e05b2d5e3c1356627 (diff)
gnu: xcb-util-errors: Update to 1.0.1.
* gnu/packages/xorg.scm (xcb-util-errors): Update to 1.0.1. Change-Id: I43b48895b9654df48bbc9898f702e24b401c8e16
-rw-r--r--gnu/packages/xorg.scm72
1 files changed, 28 insertions, 44 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 1da2acb1b2..93e4d561e9 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5601,49 +5601,33 @@ The XCB util module provides the following libraries:
"See COPYING in the distribution."))))
(define-public xcb-util-errors
- (let ((commit "5d660ebe872cadcdc85de9d6f9afe05de629c030")
- (revision "1"))
- (package
- (name "xcb-util-errors")
- (version (git-version "1.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://anongit.freedesktop.org/git/xcb/util-errors.git")
- (commit commit)
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12bah0iz5k6b9hwlc5zffyfg2gnrajll3gn5s8zmazgynvw72ahg"))))
- (build-system gnu-build-system)
- (outputs '("out"))
- (inputs
- (list util-macros xcb-proto))
- (propagated-inputs
- (list libxcb))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("python" ,python-wrapper)
- ("pkg-config" ,pkg-config)
- ,@(if (%current-target-system)
- `(("libxcb" ,libxcb))
- `())))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- ;; The default 'bootstrap' phase would run 'autogen.sh', which
- ;; would try to run ./configure and fail due to unpatched
- ;; shebangs.
- (invoke "autoreconf" "-v" "--install"))))))
- (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
- (synopsis "XCB helper library for printing information about X11 errors")
- (description
- "The XCB util module provides a number of libraries which sit on
+ (package
+ (name "xcb-util-errors")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://xcb.freedesktop.org/dist/"
+ "xcb-util-errors-" version ".tar.xz"))
+ (sha256
+ (base32 "0mzkh3xj1n690dw8hrdhyjykd71ib0ls9n5cgf9asna2k1xwha2n"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (inputs
+ (list util-macros xcb-proto))
+ (propagated-inputs
+ (list libxcb))
+ (native-inputs
+ `(("m4" ,m4)
+ ("python" ,python-wrapper)
+ ("pkg-config" ,pkg-config)
+ ,@(if (%current-target-system)
+ `(("libxcb" ,libxcb))
+ `())))
+ (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
+ (synopsis "XCB helper library for printing information about X11 errors")
+ (description
+ "The XCB util module provides a number of libraries which sit on
top of libxcb, the core X protocol library, and some of the extension
libraries. These experimental libraries provide convenience functions
and interfaces which make the raw X protocol more usable. Some of the
@@ -5653,7 +5637,7 @@ the X protocol but which has traditionally been provided by Xlib.
The XCB util-errors module provides a utility library that gives human
readable names to error codes, event codes, and also to major and minor
numbers.")
- (license license:x11))))
+ (license license:x11)))
(define-public xcb-util-image
(package