summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-28 18:44:57 +0800
committer宋文武 <[email protected]>2025-01-31 16:39:26 +0800
commit78a7d14663e8628dc897465ba21c90a8deb01549 (patch)
treeb2d3522c199e35b68a80f3cb82db1b7ddf2b68a0
parent3402c15afb587531bf69117755dc9655a9be678b (diff)
gnu: xf86-video-ark: Update to 0.7.6.
* gnu/packages/xorg.scm (xf86-video-ark): Update to 0.7.6. * gnu/packages/patches/xf86-video-ark-remove-mibstore.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: Iae0186f3b65614afd87256acabddd8e46fc3e098
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/xf86-video-ark-remove-mibstore.patch23
-rw-r--r--gnu/packages/xorg.scm7
3 files changed, 3 insertions, 28 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 48360ece55..9ececcbc01 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2399,7 +2399,6 @@ dist_patch_DATA = \
%D%/packages/patches/x265-arm-flags.patch \
%D%/packages/patches/xdg-desktop-portal-disable-portal-tests.patch\
%D%/packages/patches/xdg-desktop-portal-wlr-harcoded-length.patch\
- %D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
%D%/packages/patches/xf86-video-nouveau-fixup-ABI.patch \
%D%/packages/patches/xf86-video-savage-xorg-compat.patch \
%D%/packages/patches/xf86-video-siliconmotion-fix-ftbfs.patch \
diff --git a/gnu/packages/patches/xf86-video-ark-remove-mibstore.patch b/gnu/packages/patches/xf86-video-ark-remove-mibstore.patch
deleted file mode 100644
index 4a5b629b43..0000000000
--- a/gnu/packages/patches/xf86-video-ark-remove-mibstore.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Removes references to mibstore.h and miInitializeBackingStore, which
-have been removed from xorg-server. Zack Rusin <[email protected]>
-wrote: "It was a noop for at least 5 years and it has been removed."
-See: http://patches.openembedded.org/patch/46133/
-
---- xf86-video-ark-0.7.5/src/ark_driver.c.~1~ 2012-07-17 00:51:36.000000000 -0400
-+++ xf86-video-ark-0.7.5/src/ark_driver.c 2014-12-19 00:23:13.028931734 -0500
-@@ -39,7 +39,6 @@
- #include "compiler.h"
- #include "mipointer.h"
- #include "micmap.h"
--#include "mibstore.h"
- #include "fb.h"
- #include "ark.h"
-
-@@ -538,7 +537,6 @@
-
- fbPictureInit (pScreen, 0, 0);
-
-- miInitializeBackingStore(pScreen);
- xf86SetBackingStore(pScreen);
-
- if (!pARK->NoAccel) {
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index cca6bcde0d..61d8b303c6 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2737,18 +2737,17 @@ X server.")
(define-public xf86-video-ark
(package
(name "xf86-video-ark")
- (version "0.7.5")
+ (version "0.7.6")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-ark-"
version
- ".tar.bz2"))
+ ".tar.xz"))
(sha256
(base32
- "07p5vdsj2ckxb6wh02s61akcv4qfg6s1d5ld3jn3lfaayd3f1466"))
- (patches (search-patches "xf86-video-ark-remove-mibstore.patch"))))
+ "0p88blr3zgy47jc4aqivc6ypj4zq9pad1cl70wwz9xig29w9xk2s"))))
(build-system gnu-build-system)
(inputs (list xorg-server))
(native-inputs (list pkg-config))