summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2025-02-01 11:01:17 +0100
committerNicolas Goaziou <[email protected]>2025-02-01 11:01:17 +0100
commit2d72468698badc18c81d99aee76630609484ae4c (patch)
tree116bb020b2844e1ecf29468c4ea7529b1b702675
parentd48da2d21610f9cf5f76cd846703b12beedb1fd5 (diff)
gnu: Add simpleini.
* gnu/packages/linux.scm (simpleini): New variable. Change-Id: Ib5e582fd234e6dd302c109d9548650f8d36271a5
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e78fa27410..a3d02cf025 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017 Alex Kost <[email protected]>
;;; Copyright © 2016 Raymond Nicholson <[email protected]>
;;; Copyright © 2016 Mathieu Lirzin <[email protected]>
-;;; Copyright © 2016, 2018-2023 Nicolas Goaziou <[email protected]>
+;;; Copyright © 2016, 2018-2023, 2025 Nicolas Goaziou <[email protected]>
;;; Copyright © 2016, 2018, 2019, 2020, 2021, 2022, 2023 Ricardo Wurmus <[email protected]>
;;; Copyright © 2016 David Craven <[email protected]>
;;; Copyright © 2016 John Darrington <[email protected]>
@@ -9579,6 +9579,32 @@ compatible with Python's ConfigParser style of .INI files, including RFC
822-style multi-line syntax and name: value entries.")
(license license:bsd-3)))
+(define-public simpleini
+ (let ((commit "6048871ea9ee0ec24be5bd099d161a10567d7dc2")
+ (revision "1"))
+ (package
+ (name "simpleini")
+ (version (git-version "4.22" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brofield/simpleini")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1szaflnrzw1zx9v5g6mbbiaf9wfglp4n4jjq2793k9ryz3qxil9j"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DSIMPLEINI_USE_SYSTEM_GTEST=ON")))
+ (native-inputs (list googletest))
+ (home-page "https://github.com/brofield/simpleini")
+ (synopsis "Simple API to read and write INI-style files")
+ (description
+ "SimpleIni provides a simple API to read and write INI-style
+configuration files. It supports data files in ASCII, MBCS and Unicode.")
+ (license license:expat))))
+
(define-public xfsprogs
(package
(name "xfsprogs")