From fcf0fc0f33e6fc4ac96e585db5b048be620c3438 Mon Sep 17 00:00:00 2001
From: Hilton Chain <hako@ultrarare.space>
Date: Sun, 17 Mar 2024 08:39:45 +0800
Subject: gnu: grimshot: Fix build.

Reported in <https://issues.guix.gnu.org/69667>.

* gnu/packages/wm.scm (grimshot): Don't inherit from sway.
[source]: Switch to the new git repository.
[arguments]<#:phases>: Remove 'chdir.
[version,home-page,license]: New fields.

Change-Id: I16c81dfa3438ac0986076576bc5f543d8d4a8ec8
Reported-by: chris <chris@bumblehead.com>
---
 gnu/packages/wm.scm | 22 ++++++++++++++--------
 1 file changed, 14 insertions(+), 8 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a6f1ecd5c9..efcca9afb8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3524,20 +3524,24 @@ (define-public avizo
 
 (define-public grimshot
   (package
-    (inherit sway)
     (name "grimshot")
+    (version "1.9-contrib.0")
     (source (origin
-              (inherit (package-source sway))
-              (snippet #~(delete-file "contrib/grimshot.1"))))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/OctopusET/sway-contrib")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (snippet #~(delete-file "grimshot.1"))
+              (sha256
+               (base32
+                "16fa8l81zjy25nsky1i525hb7zjprqz74mbirm9b76pvksschdv5"))))
     (build-system copy-build-system)
     (arguments
      (list #:install-plan #~`(("grimshot" "bin/")
                               ("grimshot.1" "share/man/man1/"))
            #:phases #~(modify-phases %standard-phases
-                        (add-after 'unpack 'chdir
-                          (lambda _
-                            (chdir "contrib")))
-                        (add-after 'chdir 'patch-script-dependencies
+                        (add-after 'unpack 'patch-script-dependencies
                           (lambda* (#:key inputs #:allow-other-keys)
                             (substitute* "grimshot"
                               (("\\b(date|grim|jq|notify-send|slurp|swaymsg|wl-copy)\\b"
@@ -3559,11 +3563,13 @@ (define-public grimshot
                   slurp
                   sway
                   wl-clipboard))
+    (home-page "https://github.com/OctopusET/sway-contrib")
     (synopsis "Screenshot utility for the Sway window manager")
     (description "Grimshot is a screenshot utility for @code{sway}.  It provides
 an interface over @code{grim}, @code{slurp} and @code{jq}, and supports storing
 the screenshot either directly to the clipboard using @code{wl-copy} or to a
-file.")))
+file.")
+    (license license:expat)))
 
 (define-public wld
   (let ((commit "6586736176ef50a88025abae835e29a7ca980126")
-- 
cgit v1.2.3