From 388f27dc135b4934c0ed53e07c722662a2a5e92c Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 9 Apr 2024 14:58:20 -0400
Subject: gnu: Add jstest-gtk.

* gnu/packages/games.scm (jstest-gtk): New variable.

Change-Id: Ia02ef243ec03253f025a669f265b76ea6320fdac
---
 gnu/packages/games.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9e9b4de3da..555e70b1c9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9837,6 +9837,34 @@ (define-public flightgear
 simulator.")
     (license license:gpl2+)))
 
+(define-public jstest-gtk
+  ;; There is no recent tagged release; use the latest commit.
+  (let ((commit "60fe6ebdbc6719945be3f04988667dea569085be")
+        (revision "0"))
+    (package
+      (name "jstest-gtk")
+      (version (git-version "0.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/Grumbel/jstest-gtk")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1x5m6xvd1r9dhgzh6hp4vrszczbbxr04v7lyh4wjxxzrj3ahbmcq"))))
+      (build-system cmake-build-system)
+      (arguments (list #:configure-flags #~(list "-DBUILD_TESTS=ON")))
+      (native-inputs (list pkg-config))
+      (inputs (list gtkmm-3 libsigc++-2))
+      (home-page "https://github.com/Grumbel/jstest-gtk/")
+      (synopsis "Simple joystick tester GUI")
+      (description "@command{jstest-gtk} is a simple joystick tester based on
+GTK.  It provides a list of attached joysticks, a way to display which buttons
+and axis are pressed, a way to remap axis and buttons and a way to calibrate
+joysticks.")
+      (license license:gpl3+))))
+
 (define-public jumpnbump
   (package
     (name "jumpnbump")
-- 
cgit v1.2.3