From 2d72468698badc18c81d99aee76630609484ae4c Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Sat, 1 Feb 2025 11:01:17 +0100
Subject: gnu: Add simpleini.

* gnu/packages/linux.scm (simpleini): New variable.

Change-Id: Ib5e582fd234e6dd302c109d9548650f8d36271a5
---
 gnu/packages/linux.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

(limited to 'gnu')

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e78fa27410..a3d02cf025 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11,7 +11,7 @@
 ;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
 ;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;; Copyright © 2016, 2018-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2018-2023, 2025 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016, 2018, 2019, 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -9579,6 +9579,32 @@ (define-public libinih
 822-style multi-line syntax and name: value entries.")
     (license license:bsd-3)))
 
+(define-public simpleini
+  (let ((commit "6048871ea9ee0ec24be5bd099d161a10567d7dc2")
+        (revision "1"))
+    (package
+      (name "simpleini")
+      (version (git-version "4.22" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/brofield/simpleini")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1szaflnrzw1zx9v5g6mbbiaf9wfglp4n4jjq2793k9ryz3qxil9j"))))
+      (build-system cmake-build-system)
+      (arguments
+       (list #:configure-flags #~(list "-DSIMPLEINI_USE_SYSTEM_GTEST=ON")))
+      (native-inputs (list googletest))
+      (home-page "https://github.com/brofield/simpleini")
+      (synopsis "Simple API to read and write INI-style files")
+      (description
+       "SimpleIni provides a simple API to read and write INI-style
+configuration files.  It supports data files in ASCII, MBCS and Unicode.")
+      (license license:expat))))
+
 (define-public xfsprogs
   (package
     (name "xfsprogs")
-- 
cgit v1.2.3