From a2aa746cfe38076b87d9cde2252904c0bddd9f9e Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 21 Nov 2018 15:17:12 +0200
Subject: gnu: python-waf: Use a proper directory structure.

Fixes <https://bugs.gnu.org/25634>.

* gnu/packages/python.scm (python-waf): Replace custom 'install phase to
install "waf" binary into the bin directory. Remove the 'wrap phase.
* gnu/packages/video.scm (mpv)[arguments]: Adjust the 'setup-waf phase
accordingly.
---
 gnu/packages/python.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

(limited to 'gnu/packages/python.scm')

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d87b1315e6..c3d3c02684 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5692,9 +5692,12 @@ (define-public python-waf
            (lambda _
              (invoke "python" "waf" "--version")))
          (replace 'install
-           (lambda _
-             (copy-file "waf" %output)
-             #t)))))
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (install-file "waf" (string-append out "/bin")))
+             #t))
+         ;; waf breaks when it is wrapped.
+         (delete 'wrap))))
     (home-page "https://waf.io/")
     (synopsis "Python-based build system")
     (description
-- 
cgit v1.2.3