From 25d66b55c23b6aed19e777289b638c327b732c8e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 29 Mar 2024 19:00:37 +0000
Subject: gnu: python-distributed: Disable parallel tests.

As seen in <https://ci.guix.gnu.org/build/3708961/log/raw>, parallel
tests introduced package build regression.

* gnu/packages/python-science.scm (python-distributed) [arguments]
<#:test-flags>: Disable parallel tests.
[native-inputs]: Remove python-pytest-xdist.

Change-Id: I3a04098604fa03ab91ceb228dd70c34c3d84db78
---
 gnu/packages/python-science.scm | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

(limited to 'gnu/packages/python-science.scm')

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index a4724598b7..93d3b25272 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1673,8 +1673,7 @@ (define-public python-distributed
     (arguments
      (list
       #:test-flags
-      '(list "-n" "auto"
-             "-x" "-m"
+      '(list "-x" "-m"
              (string-append "not slow"
                             " and not flaky"
                             " and not gpu"
@@ -1882,7 +1881,6 @@ (define-public python-distributed
            python-importlib-metadata
            python-pytest
            python-pytest-timeout
-           python-pytest-xdist
            python-versioneer))
     (home-page "https://distributed.dask.org")
     (synopsis "Distributed scheduler for Dask")
-- 
cgit v1.2.3